Symptom
When calling SuccessFactors via OIDC authentication an error message is being thrown: "Failed to authenticate OIDC token"
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
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Finish the OIDC configurations across all systems (SF, IAS, and Client).
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Generate the ID token and then the OIDC/access token.
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Attempt to execute an API query using the OIDC/access token.
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Observe the error message: "Failed to authenticate OIDC token"
Cause
There are several possible misconfigurations that could cause this.
Resolution
First, please ensure that your implementation partner has followed the main documentation for this scenario: Authentication Using OpenID Connect
If that is confirmed, kindly review your implementation using the 15-minute video here: LINK
If the issue still persists, please engage SuccessFactors Support and provide the following details: SF Company ID, Support Access, IAS URL, and credentials.
See Also
Keywords
authentication, failure, error, unable, not able, api, authenticate, token, oidc, open id connect, odata, framework, oauth, successfactors, SF, identity authentication service, ias , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem
SAP Knowledge Base Article - Public