SAP Knowledge Base Article - Public

3661141 - Email address not visible in benefits helpful contacts section in the latest enrollment experience

Symptom

Email address for the user is not displayed in the "Helpful Contacts" section of the Benefits enrollment screen if the contact does not have job information data. 

Environment

SAP SuccessFactors Employee Central 2511

Reproducing the Issue

  1. Navigate to the user profile
  2. Access the Benefits section
  3. Select any benefit
  4. In the "Help and Resources" section, observe that the email address for the contact without job information is not displayed, while the phone number is visible

Cause

This is a Known Issue as the system does not show their email address from being displayed in the "Helpful Contacts" section if the phone number and email are not available directly from EC.

Resolution

As a long-term solution, a code fix, has been implemented to retrieve email and phone details from the "Benefit Contact" object when they are not available directly from Employee Central.

The fix for this issue is planned to be deployed on 1H 2026 release - Preview April 13th 2026 and Production May 15 2026. 

For release timelines, please review SAP SuccessFactors Product Release & Road Map Information.

Workaround

Add job information data to the user so the system can retrieve the email directly from EC.

See Also

Keywords

KI2H2025, BEN-20597, email not visible, benefits helpful contacts, SAP SuccessFactors Employee Central, missing email, phone visible, job information required, organizational data, benefits module, helpful contacts issue, SAP code fix, GBF, SF, latest enrollment experience 
, KBA , LOD-SF-EC-GBF , Global Benefits , Known Error

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions