SAP Knowledge Base Article - Public

3661257 - Error when validating Microsoft SQL Server connection in SAP Datasphere: "Open request could not be performed due to an error returned by DS-Lite (MDS)"

Symptom

When validating Microsoft SQL Server connection in SAP Datasphere, the following error occurs:

---------------------------------------------------------------------------------------
Connection XXXX couldn’t be established.
- Data flows can’t be used because of errors in the connection.
- Replication flows can’t be used because of errors in the connection.


Data Flows: Cause: Open request could not be performed due to an error returned by DS-Lite (MDS): "Socket closed.
Invalid attribute in connection string: DriverUnicodeType."
Replication Flows: Cause: Open request could not be performed due to an error returned by DS-Lite (MDS): "Socket closed.
Invalid attribute in connection string: DriverUnicodeType."
---------------------------------------------------------------------------------------

Environment

SAP Datasphere

Reproducing the Issue

Executing "Validate" in Microsoft SQL Server connection in SAP Datasphere.

Cause

Cause 1: SAP BTP Core Account has not been set up yet.

Cause 2: The issue can be caused by a misconfiguration in SAP Cloud Connector (SCC). Specifically, the SAP Datasphere subaccount is either missing in SCC or not correctly mapped to the intended Location ID.

Cause 3: SCC or JVM version is low.

Resolution

Resolution for Cause 1: Configure SAP BTP Core Account in Datasphere. 

  1. Navigate to: Administration -> Data Source -> Configuration -> SAP BTP Core Account
  2. Click on the pencil icon in the top right-hand corner to enable editing. 
  3. In Edit mode:
    • Add the email address.
    • Click on "Change Cloud Platform User".
  4. After clicking on "Change Cloud Platform User", necessary information will be displayed.

Resolution for Cause 2

  1. Add the Correct Subaccount in SAP Cloud Connector, follow guidelines from SAP Datasphere Help: Configure Cloud Connector | SAP Help Portal
    • Please make sure the Subaccount used in Cloud Connector is from Datasphere -> System -> Administration -> Data Source Configuration -> SAP BTP Core Account -> Subaccount.
    • See Point 1 in KBA 3456850 Pre-analysis Cloud Connector related issues when creating connection in Datasphere.
  2. Verify Location ID Consistency
    • Please make sure the Location ID defined in Cloud Connector matches exactly with the Location ID specified in the Datasphere connection settings.
    • See Point 2 in KBA 3456850 Pre-analysis Cloud Connector related issues when creating connection in Datasphere

Resolution for Cause 3: Updating both SAP Cloud Connector and SAP JVM to their latest versions. For detailed instructions on updating the Cloud Connector, please refer to KBA 2539713 (The latest version can be found at https://tools.hana.ondemand.com/#cloud). 

See Also

Keywords

connection error, DS-Lite (MDS), socket closed, invalid attribute, DriverUnicodeType, SQL Server, SAP Datasphere, Cloud Connector, replication flows, data flows , KBA , DS-DI-CON , Connections , Problem

Product

SAP Datasphere all versions

Attachments

Pasted image.png
Pasted image.png