Symptom
Unable to navigate between pages in a Canvas report due to an Application Error.
- Application error: An error occurred in processing your request
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Access a Canvas report with more than one page
- Try switching pages
- An Application Error will come up and the page will not be switched
Cause
Accessibility setting is enabled for the user in their WFA profile.
When the accessibility setting is enabled in the user's profile (usually due to the "Enhanced screen reader support and keyboard navigation" setting being enabled in Company Setting and Logo Settings), a specialized JavaScript file is loaded to support accessibility use cases. This file initiates an API call to the backend, but the corresponding handler was missing, resulting in a failure to process the request.
Resolution
The fix for this issue will be part of the 2605 release on May 2026.
Until then, an available workaround is to turn off the "Enhanced screen reader support and keyboard navigation" setting in 'Company System and Logo Settings' and syncing the affected users in WFA administration.
Keywords
Canvas, pages, WFA-39335, 2605, bug, switching, page. , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-ANA-ORD , Online Report Designer , Known Error
SAP Knowledge Base Article - Public