Symptom
- The system does not allow assigning the same account number and bank key combination to more than one company code in the Manage Bank Accounts app.
- Error message: "Bank account already exists (technical ID …)".
- Logical key (Bank Country + Bank Key + Account Number + Currency) is fixed and cannot be changed, preventing differentiation of accounts per company code.
- After company code split the bank account needs to be assigned to a new company code.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Manage Bank Accounts app.
- Attempt to assign an existing bank account (with the same account number and bank key combination) to a new company code.
- Observe the error message: "Bank account already exists (technical ID …)".
Cause
- Due to organizational changes and company code split, the same bank account needs to be assigned to a new company code. However, the fixed logical key in SAP S/4HANA Cloud Public Edition prevents assigning the same account to multiple company codes.
Resolution
- Close the existing bank account.
- Do not delete the bank account.
- Copy the closed bank account to create a new bank account with the correct company code.
- Transfer the balances from the old bank account to the new bank account.
See Also
Refer to: Closing bank account
Keywords
bank account assignment, fixed logical key, company code split, sap s/4hana cloud public edition, manage bank accounts app, error message, bank account already exists, close bank account, copy bank account, transfer balances, organizational changes , KBA , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public