Symptom
When opening a Business Object in C4C and then clicking to open the same object from another view, opens a second tab of the same object.
Environment
SAP Cloud for Customer
Reproducing the Issue
For example:
- Go to Customers > Accounts.
- Open any, e. g. ID 123 (where 123 represents the Account ID).
- Now go to Sales > Opportunities.
- Open an Opportunity that has Account ID 123 associated.
- Now in the Opportunity's header click in the Account '123'.
- See it opens a new Account tab at the op of C4C UI screen, rather than redirecting to the already open Account tab.
Cause
When opening a Business Object from different views and BOs, system will open a new tab for the same Business Object. This behavior can be observed across any other object in the system. This is not specific to Accounts or Opportunities.
Resolution
This is the expected behavior of the system. Multiple tabs will open for an object, when opening it from different views in C4C.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
See Also
KBA: 3475641 - Functionality Currently not Available
Keywords
leads, campaigns, sales quote, sales order, product, registered product, product list, contact, individual customer, business partner, employee, ticket, twice, facets , KBA , LOD-CRM-ACC , Account , LOD-CRM-OPP , Opportunity Management , LOD-LE-CQP , Customer Quote Processing , AP-RC-UIF , C4C UI Framework , LOD-CRM-SRP , Service Request Processing , Problem
SAP Knowledge Base Article - Public