Symptom
Code List Restriction applied on one field (on any entity) prevents changes to all the fields in the user interface. (Makes the page Read only).
Environment
SAP Sales and Service Cloud V2
Reproducing the Issue
- Maintain a code list restriction for one field (any entity, example: opportunities) and restrict access for a specific business role.
- Log in with a user assigned to that business role.
- Attempt to make changes in the opportunity screen.
- Observe that the screen is not editable and is Read only.
Cause
The system treats the restricted field as part of a complete instance for validation, preventing changes to any fields in that particular page.
Resolution
This is as per the design and is the expected system behavior.
Keywords
code list restriction, SAP Sales Cloud, SAP Service Cloud, non-editable fields, opportunity restrictions, business role restrictions, UI behavior, restricted access, field restrictions, SAP CRM , KBA , CEC-CRM-CLR , Code List Restrictions for SAP Sales/Service Cloud , How To
SAP Knowledge Base Article - Public