Symptom
Owner (Sales) is not determined in a Lead by "Define Rules for Lead Assignment", even though the conditions are maintained in the rule and the determination happens for other field (e.g. Owner)
Environment
SAP Cloud for Customer
Reproducing the Issue
Re-equipment that Rules are maintained in Define Rules for Lead Assignment in Sales and Campaign Settings work center view.
- Go to the Sales work center
- Go to the Leads work center view
- Click create
- Complete all the details that match a rule maintained in Define Rules for Lead Assignment (e.g. John Smith is determined for Owner (Sales) for the conditions)
- Click Save and Open
- Check Owner (Sales) field
Result: It is blank
Expected Result: John Smith is determined as Owner (Sales)
Cause
The Lead Routing Rule is limited to determining only one Sales Employee Party Category. Sales Employee Party Category includes "Service Sales Employee". If multiple Sales Employee Parties are active for a Lead, this causes issues with party determination. (e.g. Service Sales Employee is determined by the routing rule so Owner (Sales) is not determined as a result)
Resolution
To maintain only one Sales Employee Party Category for Leads.
Keywords
lead, routing rule, Employee (Sales), Define Rules for Lead Assignment, determine , KBA , LOD-CRM-LM , Lead Management , Problem
SAP Knowledge Base Article - Public