Symptom
- Cannot complete I9 Reverification E-signature step.
- Error Message: An error occurred. Please contact your system administrator.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as the I9 Reverification Signature Step responsible user
- From the To-Do tasks, find the candidate in the 'Complete e-Signing of compliance documents'
- Click 'Start'
- The error appears
Cause
Data Issue:
- The Compliance Process for the I9 Reverification is set to Canceled. As a result, the Signature Step cannot proceed hence, getting the error.
Resolution
REMINDER:
- Avoid manually updating the status of the MDF Objects, such as Compliance Process, as it may cause unexpected behavior.
WORKAROUND:
- Navigate to Manage Data > Compliance Process
- Enter the affected user's Compliance Process ID
- Take Action > Make Correction
- Change the 'Compliance Process Status' from Compliance Process Canceled to Compliance Process Started.
Since the Document Flow status is showing as In Progress, the e-signature task will appear in the responsible user's To-Do tasks or in the Home Page. Execute the above steps to resolve the error.
Keywords
I9, Reverification, I9 Reverification, Compliance Task, Compliance Process, Compliance, I-9, Signature Step, I9 Reverification Signature Step, An error occurred, Compliance process status, onboarding, OBX, ONB2.0 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
SAP Knowledge Base Article - Public