SAP Knowledge Base Article - Public

3662544 - Line breakers are not working for messaging workflow

Symptom

The special character `\n` used for line breaks in SMS workflows is not functioning as expected. In the received SMS message, the `\n` character is displayed as plain text instead of creating a new line.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator Work center.
  2. Go to Workflow Rules view.
  3. Create a new workflow rule, select Ticket as the Business Object.
  4. Go to Define Actions, select Messaging as Rule Type.
  5. Go to Text , in the notification Subject ,maintain "\n" as line breakers.
  6. Trigger the workflow, in the received SMS message, the `\n` character is displayed as plain text instead of creating a new line.

Cause

Confirmed in the backend ,line break command logic does not exist, it's not support to use line breakers in messaging workflow rule.

Resolution

It's a limitation ,please use SAP Cloud for Customer Influence Site - https://influence.sap.com/sap/ino/#/campaign/1868 and submit a new idea. 

Keywords

sms, workflow, line breaker, special character, \n, messaging, new line. , KBA , LOD-CRM-WKF , Workflow , Product Enhancement

Product

SAP Cloud for Customer core applications all versions