Symptom
The following errors can be seen on the logs after activating the transport in the Target tenant.
Activate 1 Deploying add-on solution YABCDEFGH_
Activate 1 Failed to deploy add-on solution YABCDEFGH_
Activate 1 PDI authorization removed for the user.
Environment
Cloud for Customer.
Reproducing the Issue
- Work Center: Administrator -> Transport Management
- Open the effected Transport Request.
- Activate
- Activation fails and you can see in the logs the error message 'PDI authorization removed for the user.'
Cause
-> The issue could be the status of the solution being transported - this must be In-Development" or "Assembled" solution(s). and not deployed
-> The Solution status in the target and source tenant cannot be 'In development' in both Tenants. The status must be 'Deployed in the target tenant' and 'Assembled' in the Source tenant.
-> There cannot be a production bug fix open in the solution.
Resolution
You must ensure the correct status of the PDI solution before transporting the transport request.
You must ensure there are no Production bug fix's open in the solution in the target tenant
Keywords
UTM, Transport, Unified Transport Management, Activate, PDI, Add On, authorization removed. , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem
SAP Knowledge Base Article - Public