SAP Knowledge Base Article - Public

3663961 - "Confirm Appointment" Button Doesn't Become Visible Within Orders When There Is A PDI Logic To Do So

Symptom

"Confirm Appointment" Button doesn't become visible within orders when there is a PDI logic to do so. 

Environment

SAP Cloud for Customer

Reproducing the Issue

This scenario is an example and may differ accordingly to customer custom scenario created: 

  1. Go to Customer work center.
  2. Open Residential Customer.
  3. Select one record, click to Edit.
  4. Go to Service Orders tab.
  5. Select Service Order, click to Edit.
  6. Select "Do you want to reschedule?" as "Yes"; Select "Schedule Type" field as "Field" - There is a PDI logic applied to this scenario, that should then make button "Confirm Appointment" visible.
  7. But this doesn't happen unless the page is refreshed. 

Cause

This behavior happens due to a system limitation from a Flexibility Framework perspective. The field visibility is controlled by a field from Item Level. However, by controlling visibility/read-only/mandatory should be done using fields present in Root level only. 

We support the feature of adjusting visibility/read-only/mandatory property only at field level and not at instance level. The visibility/read-only/mandatory property of the column can have either - all elements' visibility/read-only/mandatory or all elements editable at a time, depending on the latest value of the extension field indicator, (bound to its read-only property using Adjust property in Extensibility explorer)

It can not be like one element editable and other element as read-only. This is as per design of extensibility framework and cell level adjusting is neither possible now nor in the future.

That's reason why a filter by a specific Service Order within  "COD_UTILITIES_SERVICE_ORDER_EXTENSIBILITY_EC" Embedded Component, the visibility of those button work well. Because then there is one field on List and the Flexibility Framework can understand visibility of those fields. 

Resolution

Therefore, it is necessary to filter by specific Service Order on "COD_UTILITIES_SERVICE_ORDER_EXTENSIBILITY_EC" Embedded Component before opening it or to review custom logic behind both buttons. Its visibility should ideally be maintained by a field from Root node. 

Keywords

Order; Utilities; Premise; PDI; logic; Confirm Appointment; button; custom; visible; hidden; refresh; reload.  , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , AP-RC-UIF-RT , UI Framework Runtime , Product Enhancement

Product

SAP Cloud for Customer core applications all versions