SAP Knowledge Base Article - Public

3664391 - Error "There were problems getting attachment data" while the candidate submit the UK Starter Checklist - Onboarding

Symptom

  • Error message "There were problems getting attachment data" appears when attempting to submit the UK Starter Checklist form after selecting "Yes" for the 'Do you have a P45' question.
  • Error code in dev tool: "COE_GENERAL_SERVER_FAILURE""[COE0019] Error occurred while fetching attachments with name P45".

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Log into the system by the candidate.
  2. Open the Compliance task.
  3. Select "Yes" for the 'Do you have a P45' question.
  4. Attempt to add an attachment.
  5. Click "Submit".
  6. Observe the error message "There were problems getting attachment data".

Cause

  • There is a misconfiguration in Document Management Services.
  • 'Enable OpenText Integration' is enabled in Provisioning.

Resolution

  1. Go to Provisioning.
  2. Navigate to Company Settings.
  3. Disable the 'Enable OpenText Integration' switch.
  4. Save the changes.

See Also

Keywords

UK Starter Checklist, p45 attachment error, onboarding, coe_general_server_failure, compliance task, vendor configuration, DMS integration, error fetching attachments, provisioning settings, opentext integration, P45, attachment error, Compliance Task, Document Management Services, OBX, DMS, UK, Enable OpenText Integration , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding all versions