Symptom
- Error message "There were problems getting attachment data" appears when attempting to submit the UK Starter Checklist form after selecting "Yes" for the 'Do you have a P45' question.
- Error code in dev tool: "COE_GENERAL_SERVER_FAILURE""[COE0019] Error occurred while fetching attachments with name P45".
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Log into the system by the candidate.
- Open the Compliance task.
- Select "Yes" for the 'Do you have a P45' question.
- Attempt to add an attachment.
- Click "Submit".
- Observe the error message "There were problems getting attachment data".
Cause
- There is a misconfiguration in Document Management Services.
- 'Enable OpenText Integration' is enabled in Provisioning.
Resolution
- Go to Provisioning.
- Navigate to Company Settings.
- Disable the 'Enable OpenText Integration' switch.
- Save the changes.
See Also
- 3016149 - Error in getting document from DMS: Invalid service, please check if DMS has been configured properly - Onboarding
- 3075993 - [Onboarding] Application error in Configure Document Management
- 3066711 - [Onboarding] External User unable to upload attachments in PDC/Application Error in PDC when External User uploads attachments (Onboarding/Offboarding)
Keywords
UK Starter Checklist, p45 attachment error, onboarding, coe_general_server_failure, compliance task, vendor configuration, DMS integration, error fetching attachments, provisioning settings, opentext integration, P45, attachment error, Compliance Task, Document Management Services, OBX, DMS, UK, Enable OpenText Integration , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public