Symptom
- When executing the standard actions "Integration Change Quote Status" (ID: 1922) and "Creating Order Failed" (ID: 1924) in SAP CPQ, the event logs do not record the Cart ID or Cart composite number, leaving both columns empty.
- This makes it difficult to identify which Quote ID the error message belongs to, during debugging.
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Add the actions "Creating Order Failed" and "Integration Change Quote Status" to the workflow from "Order Confirmation Pending" to "Order Failed."
- Permit these actions for the user type under Workflow permissions.
- Now change the quote's status to "Order Confirmation Pending" to call these APIs.
- Make POST API calls to invoke the actions:
- Creating order failed.
- API - {{baseUrl}}/api/v1/quotes/{QuoteId}/actions/1924/invoke
- Payload - { "SalesOrderID": "<salesorderid>", "ErrorMessage": "<Custom error message>"}
- Integration Change Quote Status.
-
- API - {{baseUrl}}/api/v1/quotes/{QuoteId}/actions/1922/invoke
- Payload - { "ErrorMessage": "<Custom error message>", "RemovePreviousMessages": true, "NewStatusId": <statusid>}
- After running these successfully, it's observed in the logs that the ErrorMessage which was sent in the payload exists for both actions, but the Cart ID and the Cart composite number column is empty.
Cause
Missing functionality/Bug in the application.
Resolution
The issue is tentatively set to be fixed in the 2602 release of SAP CPQ.
See Also
3487591 - Known Issues in SAP CPQ
Keywords
sap cpq, cart id missing, cart composite number missing, event logs, integration change quote status, creating order failed, api actions, quote id logging, debugging issue, sap cpq logging problem, standard actions logging, sap cpq 2602 release , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public