SAP Knowledge Base Article - Public

3665111 - Cannot Default 'OK To Rehire' To 'No' When Reporting No-Shows

Symptom

KBA 2344097 notes that it is possible to default the 'OK To Rehire' field to 'Yes' when terminating an employee, by creating a business rule which triggers on change of the 'Termination Date' field - however, this does not work on the 'Report No Show' UI with the 'No Show Date' field.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Log into environment
  2. Go to the employee profile of the employee to be No-Showed
  3. Take Action > Report No Show
  4. When the UI loads, the 'OK To Rehire' field defaults to 'No'

Cause

This is due to the 'Termination Date' field mentioned in KBA 2344097 referring to the 'Employment Details' Termination Date field (employmentInfo-termination-date), whereas the 'No Show Date' field referred to on the No Show UI is a separate field (jobInfo-start-date). This 'No Show Date' field cannot be accessed via business rules, or configured in 'Manage Business Configuration' in order to configure the onChange rule on or about it.

Resolution

There is currently no way to configure a business rule to default the 'OK To Rehire' field on the No Show UI to 'Yes', as the field being referred to in this UI is different to the usual Termination UI and cannot be accessed via business rules or in 'Manage Business Configuration' to configure the necessary rule.

See Also

2344097 - How to Default "OK to Rehire" Field to "Yes" in Termination Screen - SAP for Me

Keywords

OK, to, rehire, OK to rehire, field, no, show, no show, no-show, termination, screen, business, rule, business rule, onchange, , KBA , LOD-SF-EC-TER , Termination Details , Problem

Product

SAP SuccessFactors HCM Core 2505