Symptom
Phone Call Activities are not being created, even after activating the "Enable Automatic Activity Creation" under "Create Activity From Interaction - Outbound" inside the Agent Desktop settings.
Environment
- SAP Service Cloud Version 2
- SAP Service Cloud and SAP Sales Cloud Version 2
Reproducing the Issue
- Open Agent Desktop and Accept the customer
- Click on the Phone Number to start the Outbound Call
- Call connected via CTI Widget
- Interaction is not saved automatically
- User has to fill it and save it manually
Cause
The CTI is not sending the ACCEPT payload once the call has been answered by the end callee
For example, with the click-to-call, we send a payload like this:
- {PhoneNumber: '+1 234-756-8900', currentSessionId: 'xxxxxxxx-xxxx-yyyy-yyyy-zzzzzzzzzzzz', Direction: 'OUT'}
- Direction: "OUT"
- PhoneNumber: "+1 234-756-8900"
- currentSessionId: "'xxxxxxxx-xxxx-yyyy-yyyy-zzzzzzzzzzzz"
Resolution
Once the call is answered, then the CTI will send the accept payload, like:
<?xml version='1.0' encoding='utf-8' ?><payload><ANI>+1 234-756-8900</ANI><DNIS>12345</DNIS><EventType>OUTBOUND</EventType><ExternalReferenceID>2C0B6D3796A0F011AA79CB31EC3CE500</ExternalReferenceID><ExternalOriginalReferenceID>2C0B6D3796A0F011AA79CB31EC3CE500</ExternalOriginalReferenceID></payload>
Then the Phone Call Activity is created
Keywords
CTI, outbound, phone call, activity, click-to-call, Agent Desktop, Customer Hub , KBA , CEC-CRM-AD , Agent desktop - live channels , How To
SAP Knowledge Base Article - Public