SAP Knowledge Base Article - Public

3665459 - GEN AI Feature Restrictions Based on Business Roles

Symptom

After removing role sap.crm.service.mlScenarioManagementGenAIService from a user you still can view Generative AI features.

Environment

  • Sales Cloud V2.
  • Service Cloud V2.

Reproducing the Issue

  1. After you activate the Generative AI features, you must assign the sap.crm.service.mlScenarioManagementGenAIService service and app to your role.
  2. Then after activating the scenarios you see that users without this role can view the Generative AI features.

Cause

The role sap.crm.service.mlScenarioManagementGenAIService is only used for the visibility of the settings for the feature. The Generative AI features themselves will then be visible to all business roles. 

Resolution

This is the expected behaviour.

To limit the view of certain tabs please consult our user guide under section Adaptation.

Keywords

Generative, AI, GEN, user, role, adaption, settings, admin, GenAIService, SAP AI Units. , KBA , CEC-CRM-ML , Machine Learning for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0