Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
The custom email template configured to notify the completion of Personal Data Collection step ("PDC" in below text) cannot work for the completion of the 2nd or subsequent PDC which is triggered due to Final Review requests data correction.
Rule configuration is referring to below guide: Creating a Business Rule to Trigger an Email Notification When the Personal Data Collection Step is Completed | SAP Help Portal
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Configure custom email template for PDC completion per guide: Creating a Business Rule to Trigger an Email Notification When the Personal Data Collection Step is Completed | SAP Help Portal
- Initiate onboarding for candidate
- Complete PDC > Go to Email Status > custom email is sent
- Complete Final Review and requesting data correction > 2nd PDC get triggered
- Complete 2nd PDC > Go to Email Status > custom email is not sent
Cause
PDC status will be set as "Completed" after completed for the first time. Hence the rule with a condition "Original Record - Process Task Status = In Progress" will fail when evaluating the second or subsequent PDC status.
Resolution
Configure a rule which will compare the latest current status to the original status, so that the custom email can be sent for the completion of the 1st and all subsequent PDC.
Sample rule configuration:
See Also
Keywords
SAP, SuccessFactors, Onboarding, Personal Data Collection, PDC, Final Review, custom email template, business rule, trigger, second task, not working , KBA , LOD-SF-OBX-EML , Notifications , Problem
SAP Knowledge Base Article - Public