Symptom
Customer is facing the error message below in message monitoring.
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Country/Region XX does not exist.\",\"code\":\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\",\"target\":\"{nationalityCountry}\"}}"
}
],
"errorDetailsAsJson": "[{\"code\":\"400\",\"message\":\"{\\\"error\\\":{\\\"message\\\":\\\"Country/Region AD does not exist.\\\",\\\"code\\\":\\\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\\\",\\\"target\\\":\\\"{nationalityCountry}\\\"}}\",\"details\":[],\"errorDetailsAsJson\":null}]"
}
Environment
- SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
In SSCv2,
- Go to "Settings".
- Go to "All Settings" tab.
- Under Integration tab, go to "Message Monitoring".
- Search for the message ID: ABC123
- Check the error message:
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Country/Region XX does not exist.\",\"code\":\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\",\"target\":\"{nationalityCountry}\"}}"
}
],
"errorDetailsAsJson": "[{\"code\":\"400\",\"message\":\"{\\\"error\\\":{\\\"message\\\":\\\"Country/Region AD does not exist.\\\",\\\"code\\\":\\\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\\\",\\\"target\\\":\\\"{nationalityCountry}\\\"}}\",\"details\":[],\"errorDetailsAsJson\":null}]"
}
Cause
In SSCv2,
- Go to "Settings".
- Under System Preference tab, go to "Language, Region, and Currency".
- Go to the tab Country/Region and search for XX (Country that is missing).
- Observe that it is not available.
Resolution
You must add the missing Country/Region
Keywords
Country/Region, Language, Region, and Currency , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , How To
SAP Knowledge Base Article - Public