SAP Knowledge Base Article - Public

3665977 - Error message employee replication: Country/Region XX does not exist

Symptom

Customer is facing the error message below in message monitoring.

{
    "code": "inbound-data-connector.132",
    "message": "Failed to process the inbound message.",
    "details": [
        {
            "code": "400",
            "message": "{\"error\":{\"message\":\"Country/Region XX does not exist.\",\"code\":\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\",\"target\":\"{nationalityCountry}\"}}"
        }
    ],
    "errorDetailsAsJson": "[{\"code\":\"400\",\"message\":\"{\\\"error\\\":{\\\"message\\\":\\\"Country/Region AD does not exist.\\\",\\\"code\\\":\\\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\\\",\\\"target\\\":\\\"{nationalityCountry}\\\"}}\",\"details\":[],\"errorDetailsAsJson\":null}]"
}

 

Environment

  • SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

In SSCv2,

  1. Go to "Settings".
  2. Go to "All Settings" tab.
  3. Under Integration tab, go to "Message Monitoring".
  4. Search for the message ID: ABC123
  5. Check the error message:
    {
        "code": "inbound-data-connector.132",
        "message": "Failed to process the inbound message.",
        "details": [
            {
                "code": "400",
                "message": "{\"error\":{\"message\":\"Country/Region XX does not exist.\",\"code\":\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\",\"target\":\"{nationalityCountry}\"}}"
            }
        ],
        "errorDetailsAsJson": "[{\"code\":\"400\",\"message\":\"{\\\"error\\\":{\\\"message\\\":\\\"Country/Region AD does not exist.\\\",\\\"code\\\":\\\"sap.crm.common.commonMessage.countryCodeValueDoesNotExist\\\",\\\"target\\\":\\\"{nationalityCountry}\\\"}}\",\"details\":[],\"errorDetailsAsJson\":null}]"
    }

 

Cause

In SSCv2,

  1. Go to "Settings".
  2. Under System Preference tab, go to "Language, Region, and Currency".
  3. Go to the tab Country/Region and search for XX (Country that is missing).
  4. Observe that it is not available.

Resolution

You must add the missing Country/Region

Keywords

Country/Region, Language, Region, and Currency , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions