Symptom
You are working with business users, and notice that the ID of a user is not saved with the next ID in the number range.
For example, after creating a business user which got assigned to User ID CB00000002, the next created user may be assigned to ID CB0000008, instead of CB00000003.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Maintain Business Users app.
- Click on New.
- Select the business partner to be assigned to the user.
- Fulfill the required fields for the user.
- Click on Save.
Here, it is possible to see that the User ID assigned does not immediately follow the next ID in the number range.
Cause
The system utilizes a buffering for the user IDs. This causes a couple of IDs to be locked whenever a new instance is to be created in the system, even if the new user is not yet saved.
Depending on other concurrent operations in the system (including server operations), the buffers may be reset hence causing sequence gaps in the user IDs allocated.
Resolution
The system works as expected.
Keywords
CB User, IAM, BUM , KBA , CA-GTF-BUM , Business User Management , Problem
SAP Knowledge Base Article - Public