Symptom
- The DRTM/DRM Inactive Candidate Purge or Inactive Application Purge jobs have been running continuously for several days and ended up as Failed.
- The Provisioning job "Data Management -- Process Request" (drmRequestProcess) repeatedly fails and recovers.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Navigate to Purge Request Monitor > Purge Progress & Results.
- Notice that the Inactive Candidate Purge or Inactive Application Purge jobs have been running continuously.
Cause
This behavior often occurs when there is a large volume of data to purge, which can take several days to complete.
During this process, the server may force long-running jobs to stop, resulting in a Failed status and no purge report being generated.
This does not imply that no records have been purged. The purging process proceeds normally until it is halted. In some instances, there may be a large volume of data along with errors in certain records. Nevertheless, if an individual record encounters an error, the job will continue purging the remaining records.
The primary reason for the long-running process is the volume of data.
Resolution
- Separate purge jobs by country when possible to reduce the data volume per job.
- Re-run the purge job to resume the purging process.
- Verify purged records by checking the 'Anonymized Flag' in the Candidate and Application reporting entities. This will help confirm if the number of purged records is increasing as the job runs.
If certain candidate or application is not purged after multiple attemptes, it might be due to data volume or errors. The Support team can assist in identifying any issues. Please provide the following details in the Support ticket:
- Company ID
- Support access
- Sample candidate or application ID
- The Request Name in 'Purge Request Monitor > Purge Progress & Results'
(For SAP Support only: see internal memo for details)
See Also
Keywords
RCM, DRTM, DRM, Data Retention, Purge, Candidate, Job Application, Inactive, Never Ending, Completing, Failed, Recovered, Interrupted, drmRequestProcess, Anonymize , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-APP , Applicants and Job Applications , Problem
SAP Knowledge Base Article - Public