Symptom
Placeholders in Signature Template are not getting populated for users added to specific Business Roles.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
This scenario is applicable for any entity that uses Signature Templates in Emails. Below are the steps to reproduce the issue in Case Entity:
- Go to Cases.
- Open a Case in detail view.
- Click on Create Email.
- Enter all necessary details and add a signature template.
- Notice that placeholder are not populated with desired value.
Cause
Employee Business Service - sap.crm.md.service.employeeService is not assigned to the Business Role. For signature template placeholders, the data is fetched from Employee Service. So, if Employee Business Service is not assigned to the Business Role, then data will not get fetched for the logged in User.
Resolution
Add the Employee Business Service by following below steps:
- Go to Settings.
- Search for Roles.
- Open the role in Detail View.
- Under Business Services section, click on Search and Add Business Services.
- Add sap.crm.md.service.employeeService .
- Click on Save.
Keywords
Signature Template, Business Roles, Templates, Business Service, App List, Placeholder, Employee, Value, Empty, Case, Service, Roles, Restriction , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-EMP , Employee for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public