SAP Knowledge Base Article - Public

3666672 - Assign a service contract on a service order created from a service quotation

Symptom

It's required to have the service contract assigned on a service order created as a follow-up from a service quotation. The requirement is to assign the contract on the service order, and not on the service quotation, because due to business restrictions, this is the process step where the contract is created and ready to be assigned.

Environment

SAP S/4HANA Cloud Public Edition

Cause

It's not possible to change the contract assignment after the service order is created.

So if the service order is created with no contract, then no contract can be added. If it has been created with a contract, the assignment cannot change.

The reason behind this behavior is that if allowing the service contract to be selected on the follow-up service order (created from the quotation) then the price will be modified and it will be different from quote price accepted by the customer.

Resolution

It's understandable how the functionality to select the contract only on the service order would be beneficial for the business and would align more with the business necessities, so please consider creating a feature request for this business requirement. This will inform the responsible developers as to what additional functionality should be considered for future releases. 

See Also

KBA 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product

Keywords

service order, service quotation, service contract, contract selection, no assignment, contract assignment, you can't change the assigned service contract as the item is released, SVO, SVQ, SVC , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions