Symptom
- The Payment Reference field is not visible or editable in the UI when creating Payment Advice manually.
- The Payment Reference field appears via API but is not accessible in Personalization Mode.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to the Liquidity Management Work Center.
- Under Common tasks, click on New Bank Payment Advice.
- Click on View All.
- Click on the Profile icon, select Start Personalization Mode, and then choose Payment Advice Data.
- Observe that the Payment Reference field is greyed out.
Cause
Observe that in Personalization Mode you need to make changes and enable Payment Reference Field.
Resolution
- Go to New Bank Payment Advice and click View All.
- Select the Advice Type as Bank Debit Advice.
- Set the Payment Method to Direct Debit.
- Check the Posting Advice checkbox.
- Click on the Profile icon and Start Personalization Mode.
- Verify that the Payment Reference checkbox is enabled and available for selection.
Keywords
payment reference field, UI issue, payment advice, personalization mode, bank debit advice, direct debit, payment method, liquidity management, payment advice data, field not visible, field not editable, SAP Business ByDesign, manual payment advice creation, API payment advice creation, payment reference checkbox. , KBA , SRD-FIN-MOP , Payment Management , How To
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public