SAP Knowledge Base Article - Public

3666797 - New Picklist Version was created after Import in SuccessFactors

Symptom

After importing new Picklist values, a new version was created instead.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SucessFactors HCM Core

Reproducing the Issue

  1. Log in to the instance.
  2. Navigate to Import and Export Data.
  3. Select Picklist on the Select Generic Object field. 
  4. Import the picklist csv you created.
  5. After the import, navigate to the Picklist Center.
  6. Observe that there are two versions of the Picklist created instead of having the current active one updated. 

Cause

  • The issue occurred due to a mismatch in the effective dates between the existing version of the state and the imported file.
  • Example: The effective date of the initial state version was set to January 1, 1901, while the effective date on the CSV file was set to January 1, 1900. This discrepancy led to the creation of a new version of the Picklist.

Resolution

Ensure that the effective date on the csv file you are uploading match the effective date of the Picklist version you want to edit. 

Depending on your configuration, you may also Deactivate the newly created Picklist before uploading the corrected version. Here's how: Deactivating a Picklist Version | SAP Help Portal

See Also

Help Guides: 

Keywords

mport error, new version created, picklist error, java.lang.NullPointerException, external code mismatch, effective date mismatch, MDF picklist, parent-child relationship, import validation error, duplicate records, new version, picklist, LOD-SF-MDF-PKL, LOD-SF-PLT-PCK, picklist, picklist center, version, effective date , KBA , LOD-SF-MDF-PKL , Picklists , LOD-SF-PLT-PCK , Picklist Management Issue , LOD-SF-MDF-IMP , Import and Export Issues , Problem

Product

SAP SuccessFactors HCM Core all versions