Symptom
The location field is not automatically populated from the account record when creating an appointment, even there is an address maintained in related account.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Customers - Account.
- Open an Account
- Go to Activities - Appointment - New.
- Fill in the mandatory fields (e.g., Organizer, Category - Customer visit).
- Save the appointment.
- Check the Location field; it remains empty.
Cause
A default value with extra spaces has been set for the location field, preventing proper initialization.
Resolution
- Verify if a default value with extra spaces has been set for the location field in the account record.
- Remove any extra spaces from the default value in the location field.
- Save the changes in the account record.
- Create a new appointment and verify if the location field is correctly populated.
See Also
- Refer to: KBA 3112956 for additional information regarding location determination in SAP C4C.
- Refer to: KBA 2497419 for guidance on ABSL scripting in SAP C4C.
Keywords
location field, C4C, appointment , account activities, default value, extra spaces, field initialization, location, address , KBA , LOD-CRM-ACT , Activities , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public