Symptom
You are replicating Business Partner to C4C and it is failing due to a postal code length issue - "Postal code X must have length Y" (where X is a generic postal code ID and the Y is the length accepted by C4C), even the postal code length for the Country was changed to Y digits on the C4C Business Configuration Countries/Regions fine-tuning activity.
Environment
- SAP Cloud for Customer
- SAP Cloud for Customer Integration with SAP ERP
- SAP Cloud for Customer Integration with SAP S/4HANA
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query Erroneous
- Search for message ID with error "Postal code X must have length Y".
Cause
Even after defined the Postal Code length on the C4C Business Configuration, this error is due to the fact the postal code is incorrect for ISO standards. The postal code must have length equal to Y.
As you have maintained the Postal Code Check Rule as '9 - Check against country-specific edit format', the system correctly displays the error message.
Resolution
An option, on the C4C system, is to change the Postal Code Check Rule, like '5 - Maximum value length' if the length cannot be used as Y.
For this, please follow:
-
Go to the Business Configuration Work Center.
- Search for the activity Countries/Regions.
- Select Edit Countries.
- Search for the country you are replicating.
- Select the Postal Attributes Tab.
- Change the Postal Code Check Rule
See Also
KBA 2708855 - Message Fails When Replicating Customers with a specific Postcode Length
Keywords
Postal Code, length Y, Length, Replication, Business Partner, C4C, Cloud for Customer, Postal, BP, Business, Partner, Replication, ISO. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , AP-RC-CTY , Countries , How To
SAP Knowledge Base Article - Public