Symptom
In SAP S/4HANA Cloud Public Edition, when using an application in Accounts Payable / Receivable area which process a high-volume data, the system throws an error TSV_TNEW_PAGE_ALLOC_FAILED
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open an app for clearing process
- Execute the program with high-volume processing
- Error raised
Cause
The TSV_TNEW_PAGE_ALLOC_FAILED exception signals an out-of-memory condition for a specific request. For SAP S/4HANA Cloud Public Edition, the system is architected with non-adjustable parameters. These memory governance settings are applied universally to all environments (production and non-production) and cannot be overridden.
Resolution
Optimize the processing request by reducing the overall volume of data being processed or generated. This means refining the request to streamlining the data processing to minimize the size.
See Also
3590659 - Error TSV_TNEW_PAGE_ALLOC_FAILED when using Sales APIs in SAP S/4HANA Cloud Public Edition
Same situation in other high-volume processing data.
Keywords
TSV_TNEW_PAGE_ALLOC_FAILED, Memory Management , KBA , FI-FIO-AR-2CL , Fiori UI for Accounts Receivable (Public Cloud) , BC-CST-MM , Memory Management , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Known Error
SAP Knowledge Base Article - Public