SAP Knowledge Base Article - Public

3667385 - [2H 2025] Unable to login or create new profile in External Career Site - Recruiting Management

Symptom

  • External candidates are unable to log or create new profile in External Career Site
    • When logging in, after entering email and password, and then clicking submit, the page reloads back to login page
    • When creating a new profile, after filling in all required information and clicking submit, the page reloads back to account creation page

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Navigate to the external Career Site
  2. Attempt to log in using existing credentials
  3. Observe that the page refreshes and redirects to the same login screen without any error message
  4. Attempt to create a new account by filling in all required fields and submitting the form
  5. Observe that the page reloads back to the account creation page without creating the account

Cause

Engineering identified that the issue was caused by changes introduced in a backend toggle during Preview Release.

Resolution

Engineering identified that the changes leading to the issue were controlled by a backend toggle.

The toggle was turned off in all Data Centers. The issue was resolved, and candidates can now log in and create accounts successfully.

See Also

2692971 - SAP SuccessFactors Known Issues for the 2H 2025 Release

Keywords

external career site, login, account creation, 2H2025. KI2H2025  , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Known Error

Product

SAP SuccessFactors Recruiting 2511