Symptom
- External candidates are unable to log or create new profile in External Career Site
- When logging in, after entering email and password, and then clicking submit, the page reloads back to login page
- When creating a new profile, after filling in all required information and clicking submit, the page reloads back to account creation page
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Navigate to the external Career Site
- Attempt to log in using existing credentials
- Observe that the page refreshes and redirects to the same login screen without any error message
- Attempt to create a new account by filling in all required fields and submitting the form
- Observe that the page reloads back to the account creation page without creating the account
Cause
Engineering identified that the issue was caused by changes introduced in a backend toggle during Preview Release.
Resolution
Engineering identified that the changes leading to the issue were controlled by a backend toggle.
The toggle was turned off in all Data Centers. The issue was resolved, and candidates can now log in and create accounts successfully.
See Also
2692971 - SAP SuccessFactors Known Issues for the 2H 2025 Release
Keywords
external career site, login, account creation, 2H2025. KI2H2025 , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Known Error
Product
SAP SuccessFactors Recruiting 2511
SAP Knowledge Base Article - Public