Symptom
- An intermittent error occurs when calling the CPQ 2.0 Quote API from middleware.
- Error message: "Sorry for the inconvenience, but there seems to be an error in the system. An automatic notification has been sent our way and we'll be fixing the error as soon as possible. In the meantime, you can go back to the login page and continue working in SAP CPQ."
- Observation: The error does not occur when the same cookie is reused in Postman. However, clearing cookies and retrying the API results in the error.
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Call the CPQ 2.0 Quote API from a middleware such as Postman using the provided URL: https://<CPQ Url>/api/rd/v1/ApprovalHistory/GetApprovalHistoryModelInitData?quoteid=<QID>&ownerid=<OID>
- Clear cookies and retry the API call.
- Observe the error message.
Cause
The issue has been identified as a bug in the CPQ 2.0 Quote API.
Resolution
The bug is tentatively scheduled to be fixed in the SAP CPQ 2602 release.
See Also
3487591 - Known Issues in SAP CPQ
Keywords
intermittent error, cpq 2.0, quote api, middleware, error code, random error, cookie issue, postman, sap cpq, api error, approval history, bug fix, 2602 release, cpq known issues , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public