SAP Knowledge Base Article - Public

3667475 - Blocked Invoice Requests Due To Execution Block In Service Orders.

Symptom

The invoice requests are in a blocked status and there is warning message: "Document blocked for delivery."

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to WoC: Customer Invoicing.
  2. Open the View: Invoice Requests.
  3. Select Service Order Invoice Request ABC (ABC represents ID of  Service Order Invoice Request).
  4. See the status was Blocked.
  5. Open Service Order DEF (DEF represents ID of  Service Order).
  6. Review the warning message: Document blocked for delivery.

Cause

The blocked status is caused by the presence of an Execution Block in the Service Orders, which was not removed prior to their cancellation.

Resolution

It is required to remove the Execution Block in the Service Order by removing the Reason for Rejection, then removing the Execution Block and then adding the Reason for Rejection again.

Following below steps:

  1. Navigate to WoC: Service Order.
  2. Open the View: Service Order Processing.
  3. Open Service Order DEF (DEF represents ID of  Service Order).
  4. Click on View All, then go to the General tab and the Main information sub tab. 
  5. Remove the Reason for Rejection in the Service Order.
  6. Remove the Execution Block.
  7. Then reapply the Reason for Rejection.

Keywords

blocked invoice request, execution block, service order, reason for rejection, document blocked for delivery, customer invoicing, invoice request, blocked status, inconsistent invoice request , KBA , SRD-CRM-INV , Customer Invoicing , SRD-CRM-SEO , Service Orders , Problem

Product

SAP Business ByDesign all versions