SAP Knowledge Base Article - Public

3667729 - Unable To Assign Null Value Using Determinations

Symptom

User is unable to set Case Processor as Null using Determinations.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Settings.
  2. Navigate to Extensibility Administration.
  3. Go to Case Service and Case.
  4. Under Determinations tab, create new Pre-hook determination using Forms.
  5. Set the Assignment as {processor/displayid} = (null) or {processor/displayid} = (' ').
  6. Click on Save.
  7. Go to Cases Workcenter and open a case in detail view.
  8. Perform an action on Case such that the Pre-hook determination is triggered.
  9. Notice that the 'Assigned To' field is not set to null.

Cause

Configuration Issue. For clearing a field using Determinations, both ID and Display ID should be set as null.

Resolution

In the Determination rule, set 2 Assignments in Assignment Block as follows:

  1. {processor/id} = ( '' ) AND
  2. {processor/displayId} = ( '' )

See Also

Determination, Case, Processor, Assigned To, Null, Empty, Initial, Blank, Display ID, ID, Service, Rule, Pre-hook, Assign, Assignment

Keywords

KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM-DTR , Determination for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions