Symptom
User is unable to set Case Processor as Null using Determinations.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Settings.
- Navigate to Extensibility Administration.
- Go to Case Service and Case.
- Under Determinations tab, create new Pre-hook determination using Forms.
- Set the Assignment as {processor/displayid} = (null) or {processor/displayid} = (' ').
- Click on Save.
- Go to Cases Workcenter and open a case in detail view.
- Perform an action on Case such that the Pre-hook determination is triggered.
- Notice that the 'Assigned To' field is not set to null.
Cause
Configuration Issue. For clearing a field using Determinations, both ID and Display ID should be set as null.
Resolution
In the Determination rule, set 2 Assignments in Assignment Block as follows:
- {processor/id} = ( '' ) AND
- {processor/displayId} = ( '' )
See Also
Determination, Case, Processor, Assigned To, Null, Empty, Initial, Blank, Display ID, ID, Service, Rule, Pre-hook, Assign, Assignment
Keywords
KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM-DTR , Determination for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public