SAP Knowledge Base Article - Public

3667846 - Customer Contracts Not Visible in "My Contracts" or "My Active Contracts" Filters

Symptom

In the system's Contracts view, it is not possible to find some customer contracts created by you under the "My Contracts" or "My Active Contracts" filters from the dropdown selection.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Sales Orders workcenter.
  2. Go to the Contracts view.
  3. Select "All Contracts" from the dropdown list.
  4. Search for the Contract ABC (Where ABC represents a specific contract ID). The Contract ABC is displayed under the query results.
  5. Change the filter to "My Contracts" or "My Active Contracts" from the dropdown list.
  6. Search for the ID ABC again.

The contract is not displayed under these views.

Cause

The reasons why some contracts are not visible on these views might be the following:

  • The Contracts available under the "My Contracts" filter are the sales documents which have the logged-in user assigned as the Contract Administrator role.
  • The view "My Active Contracts" works in a similar way, however, it will show, among these contracts, only the ones which are currently within the contract's validity (between the contract's start and end dates). 

Resolution

This is the expected system behavior.

The desired contracts will be displayed under the "My Contracts" and "My Active Contracts" views once the user who is logged on in the system is the same person as the document's Contract Administrator.

See Also

KBA 1794970 - The Filter "My Accounts" in the Accounts View Does not Show the Expected Data

Keywords

My Contracts view, My Active Contracts, Sales Orders, Search, Query, Views, Filter, not working, not displaying, not showing, customer contract, logged-in user, display issue, byd. , KBA , AP-CCP-CC , Customer Contract , AP-SLO-SO , Sales Order , AP-CCP , Customer Contract Processing , How To

Product

SAP Business ByDesign all versions