Symptom
When converting a Lead to an Opportunity, custom fields are not transferred to the new Opportunity.
Environment
SAP Sales Cloud Version 2
Reproducing the Issue
- Open any Lead containing a custom field
- Convert the Lead to an Opportunity
- Observe that the data is not transferred to the custom field on the Opportunity, despite the field being available there.
Cause
Currently, the custom fields are reserved for each entity. Therefore, by standard, it is not possible to transfer the values from one custom field in the Lead to another custom field in the Opportunity.
Resolution
This is the expected behaviour of the system.
In case you would like to achieve this using custom methods, this may be possible using external hooks.
Keywords
lead conversion, lead convert to opportunity, custom fields, custom field transfer , KBA , CEC-CRM-GS , Guided Selling/Opportunity for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public