Symptom
- "Internal Server Error" met when opening Joule in SF
- The SuccessFactors instance continues to point to the old URL of the Joule tenant despite a new formation being successfully configured in BTP > Joule Subaccount, with new Joule URL generated.
- The new formation is successfully set up without errors and new Joule application is auto-generated in IAS, however The SuccessFactors instance continues to point to the old Joule URL.
- Clicking the Joule icon in the SuccessFactors instance redirects to the old/non-existent Joule tenant URL, caused user cannot open Joule in SF.
Environment
- SAP SuccessFactors HCM Suite
- Joule
Reproducing the Issue
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Log in to the SAP BTP Cockpit.
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Navigate to the Subaccount where the Joule integration is set up.
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Perform the Unsubscribe from Joule | SAP Help Portal activity following the steps described in the SAP Help Portal.
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Confirm that the unsubscribe process completes successfully without any errors.
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Run the Joule Booster again from the SAP BTP Cockpit to create a new Joule tenant.
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Go to BTP > Formation and verify that a new Joule tenant is generated and linked with the same SuccessFactors instance.
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In Identity Authentication Service (IAS), verify that the new Joule tenant appears as an application.
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From the SuccessFactors Home Page, click the Joule icon.
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Observe that the system still redirects to the old (now unsubscribed) Joule tenant URL, which no longer exists.
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As a result, users are unable to open Joule successfully and may encounter an error or blank Joule window.
Cause
One SFSF tenant can only be connected to one Joule tenant, if original Joule tenant not offboarded correctly, new onboarding will be failed due to backend validation and still connect to old Joule tenant.
Resolution
To fix the issue, kindly follow the below steps:
- Go to BTP > Formations
- Exclude the SuccessFactors system from the formation by clicking "Exclude" button. Wait for the formation to return to the "Ready" state.
- Include the same SF system back into the formation.
- Access SuccessFactors instance, open Joule, it should pointed to the new Joule tenant.
If you still met same problem after trying above steps, kindly create a customer case to LOD-SF-PLT-JOU component with below information:
- Screenshot: BTP Formation information of your SF & Joule integration.
- Share network trace file when reproducing this issue: KBA:2760505 - How to Generate Network trace and Console Logs in Chrome, IE and Firefox - SAP SuccessFactors - SAP for Me
- Basic information of troubleshooting Joule issues: KBA: 3475057 - How to check and provide basic information while troubleshooting Joule related issues in SuccessFactors? - SAP for Me
See Also
Keywords
successfactors, Platform Joule, URL not updating, bot instance URL, BTP formation, IAS admin, old formation, new formation, SuccessFactors instance, troubleshooting, integration, configuration issue, SF, old domain, Internal Server Error , KBA , LOD-SF-PLT-JOU , Joule in SuccessFactors , CA-JOULE , Joule , How To
SAP Knowledge Base Article - Public