SAP Knowledge Base Article - Public

3669240 - Unable to view position workflow in Manage Workflow Requests page despite having all permissions - Employee Central

Symptom

  • HR employee is unable to view a workflow in the Manage Workflow Requests page despite having all permissions.
  • The issue persists when proxying as a specific HR user.
  • The affected position workflow does not appear in the Manage Workflow Requests page, while a similar Position ID (22004678) is visible.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

Make sure the HR User does not have Manage Workflow Requests permission over position workflow's inititiator, then:

  1. Proxy as an HR User
  2. Navigate to the Manage Workflow Requests page.
  3. Apply filters: Object: Position and Status: Pending.
  4. Observe that the position workflow you are looking for does not appear in the results.

Cause

HR User does not have Manage Workflow Requests permission over position workflow's initiator.

Resolution

Grant affected HR User the Manage Workflow Requests permission over workflow initiator.

See Also

Keywords

workflow not visible, manage workflow requests, sap successfactors, employee central, initiator, position workflows, HR, permissions issue, pending status, position, troubleshooting, proxy user, workflow approval stage, SF, EC, POS, WFL , KBA , LOD-SF-EC-POS-WFL , Position Workflows , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-POS , Position Management , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions