SAP Knowledge Base Article - Public

3669456 - Error FH215 "G/L account type cannot be changed because transaction data exists" in Manage G/L Account Master Data app - SAP S/4HANA Cloud Public Edition

Symptom

In Manage G/L Account Master Data app, click edit to change G/L account type. When saving the change, error FH215 "G/L account type cannot be changed because transaction data exists" occurred.

Environment

SAP S/4HANA Cloud Public Edition

Cause

Due to compliance and audit reasons, changing account type is not allowed if postings exist in the production system.

Resolution

The error is raised correctly to ensure the consistency of existing data.

The workaround is to create a new account with correct settings and post the balance of the current account with wrong settings to the new account.

Keywords

FH215, G/L account type, transaction data exists , KBA , FI-GL-GL-N-2CL , Master Data (Public Cloud) , FI-GL-GL-N , Master Data , Problem

Product

SAP S/4HANA Cloud Public Edition all versions