SAP Knowledge Base Article - Public

3669781 - The reset password link is not working for rehire candidates whose onboarding was previously cancelled - Onboarding

Symptom

Reset password functionality is not working for rehire users with old employment when onboarding is canceled and reinitiated in Recruiting Management.

Environment

SAP SuccessFactors Onboarding.

Reproducing the Issue

  1. Initiate the candidate in RCM;
  2. Accept Rehire;
  3. First Welcome Message will be triggered;
  4. Cancel the Onboarding in Dashboard;
  5. Reinitiate the candidate in RCM;
  6. Second Welcome Message will be triggered;
  7. Click on Reset Password Link;
  8. The page keeps loading.

Cause

This is a Known issue and occurs due to a backend error where the email token is validated but fails to find the product name

Resolution

A code correction has been created to address the backend issue, with a tentative fix planned for the upcoming 2605 release. As a workaround, if any affected users require data correction to resolve the link issue, please create a support ticket. A script can be run to apply the necessary fix.

    Mark this article as favorite to receive updates regarding the permanent fix.

    Also, the code correction can be tracked with the Account Manager using the code OBX-40778.

    See Also

    Keywords

    reset password, rehire with old employment, onboarding cancellation, rehire welcome message, password reset link, email token validation, database script, OBX-40778, rehire user, KI1H2025 , KBA , LOD-SF-OBX-EML , Notifications , Known Error

    Product

    SAP SuccessFactors Onboarding 2505 ; SAP SuccessFactors Onboarding 2511