SAP Knowledge Base Article - Public

3669804 - All users assign to a custom role are not visible in "Assign role to user" panel for that specific custom role in SAP Analytic Cloud (SAC).

Symptom

All users assign to a custom role are not visible in "Assign role to user" panel for that specific custom role in SAC.

Eg: The custom role XYZ is assigned to 16 teams, but the system displays "16 teams and 7 users." The 7 users are not listed in "Assign role to user" panel for the XYZ custom role.

Environment

SAP ANALYTICS CLOUD 2025.14.12 

Reproducing the Issue

  1. Login to SAC
  2. Navigate to Security --> Roles --> Custom role "XYZ"
  3. Click on "Assign role to user" panel

Notice: All the users are not listed in the "Assign role to user" panel

Cause

 The users which are not showing up were created as concurrent users. You can confirm the same by :

  1. Open Security->Activities
  2. Search for any affected user 
  3. Select the "Create" link in the Activity column
  4. Observe that the IS_CONCURRENT value is 1 (indicating a concurrent user)

Resolution

Remove the concurrent flags from the default roles and users by performing the following steps in the UI.
For custom role XYZ, do the following:  
        1. Open the Role Configuration dialog in the role details page
        2. Uncheck the "Use as Default Role" button ( if checked ) and save the role
        3. Open the Role Configuration dialog again.
        4. Check the Use as Default Role button and save the role again.
To update the users : 
        1. export the users to a csv file from the Security->Users list
        2. update the users to have the IS_CONCURRENT flag set to 0 and reimport users.

See Also

Keywords

sac, user, license, concurrent , KBA , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0