Symptom
All users assign to a custom role are not visible in "Assign role to user" panel for that specific custom role in SAC.
Eg: The custom role XYZ is assigned to 16 teams, but the system displays "16 teams and 7 users." The 7 users are not listed in "Assign role to user" panel for the XYZ custom role.
Environment
SAP ANALYTICS CLOUD 2025.14.12
Reproducing the Issue
- Login to SAC
- Navigate to Security --> Roles --> Custom role "XYZ"
- Click on "Assign role to user" panel
Notice: All the users are not listed in the "Assign role to user" panel
Cause
The users which are not showing up were created as concurrent users. You can confirm the same by :
- Open Security->Activities
- Search for any affected user
- Select the "Create" link in the Activity column
- Observe that the IS_CONCURRENT value is 1 (indicating a concurrent user)
Resolution
Remove the concurrent flags from the default roles and users by performing the following steps in the UI.
For custom role XYZ, do the following:
1. Open the Role Configuration dialog in the role details page
2. Uncheck the "Use as Default Role" button ( if checked ) and save the role
3. Open the Role Configuration dialog again.
4. Check the Use as Default Role button and save the role again.
To update the users :
1. export the users to a csv file from the Security->Users list
2. update the users to have the IS_CONCURRENT flag set to 0 and reimport users.
See Also
-
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Keywords
sac, user, license, concurrent , KBA , LOD-ANA-ADM , SAC Administration , Problem
SAP Knowledge Base Article - Public