SAP Knowledge Base Article - Public

3670324 - Error when verifying connection between 365 and Interview Scheduling: "ServiceApplicationException occurred while validating RCM EAS Validation for OUTLOOK_CALENDAR"

Symptom

When trying to verify the connection between Microsoft 365 and Interview Scheduling in Manage Recruiting Settings, the following error occurs:

errorId=null, timestamp=null, errorMessage=ServiceApplicationException occurred while validating RCM EAS Validation for OUTLOOK_CALENDAR, server=237pc57bcf13, versionInfo=Release%3A%20%20%2020250904173002%0AServer%3A%20%20%20%20237pc57bcf13%0ATimestamp%3A%202025-09-17T12%3A23%3A53.098%2B000

Or

When setting up an online interview from “Interview scheduling” (Using TEAMs) and try to “Book this slot for the candidate,” and get this error:
“RemoteException occurred while saveAndSendEmail”

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Admin Center>Manage Recruiting Settings
  2. Scroll down to "Interview Settings"
  3. Click on "Verify and Connect" under "Microsoft Integrations with Interview Scheduling" section
  4. Observe the error message: errorId=null, timestamp=null, errorMessage=ServiceApplicationException occurred while validating RCM EAS Validation for OUTLOOK_CALENDAR.

Cause

  • Backend logs indicate the error code MailboxNotEnabledForRESTAPI.
  • Backend logs indicate error code ErrorQuotaExceeded Error message: The process failed to get the correct properties. 
  • The error message specifies that the mailbox is either inactive, soft-deleted, or hosted on-premise. 

Resolution

Review the configuration of the service account with the IT team.
Ensure the service account is active in Azure (MS Entra). 

1. The error seems to have been caused by a access issue on the Azure side. The service account has to be added to a group in Azure to resolve the issue. 

2. With regards to the permission, the Mail.ReadWrite permission is only needed if there are attachments greater than 3MB on any meeting invites or emails related to the integration sent.

3. Also, please make sure if there is an issue with the availability not pulling through correctly in Interview Scheduling which might be due to incorrect email being set for your user in Azure account (shouldn't be a dummy user but needs to match our outlook email)

For the error ErrorQuotaExceeded, the storage quota needs to be updated for the service account mailbox: https://learn.microsoft.com/en-us/troubleshoot/power-platform/dataverse/email-exchange-synchronization/errorquotaexceeded-exchange-server-returned-403-error

See Also

2997844 - Error on Interview Scheduling with Outlook Integration using Modern Authentication - Recruiting Management

Keywords

interview settings, azure, service account configuration, interview scheduling, modern authentication, MailboxNotEnabledForRESTAPI, mailbox inactive, soft-deleted mailbox, hosted on-premise mailbox, Outlook integration, Azure mailbox configuration, Interview Scheduling error, service account validation, EAS validation, REST API mailbox error, ErrorQuotaExceeded,  “RemoteException occurred while saveAndSendEmail” , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem

Product

SAP SuccessFactors Recruiting all versions