Symptom
When trying to verify the connection between Microsoft 365 and Interview Scheduling in Manage Recruiting Settings, the following error occurs:
errorId=null, timestamp=null, errorMessage=ServiceApplicationException occurred while validating RCM EAS Validation for OUTLOOK_CALENDAR, server=237pc57bcf13, versionInfo=Release%3A%20%20%2020250904173002%0AServer%3A%20%20%20%20237pc57bcf13%0ATimestamp%3A%202025-09-17T12%3A23%3A53.098%2B000
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Admin Center>Manage Recruiting Settings
- Scroll down to "Interview Settings"
- Click on "Verify and Connect" under "Microsoft Integrations with Interview Scheduling" section
- Observe the error message: errorId=null, timestamp=null, errorMessage=ServiceApplicationException occurred while validating RCM EAS Validation for OUTLOOK_CALENDAR.
Cause
As per backend logs, the following error appears:
Error code: MailboxNotEnabledForRESTAPI Error message: The mailbox is either inactive, soft-deleted, or is hosted on-premise.
Resolution
Review the configuration of the service account with the IT team and ensure that the service account is active in Azure (MS Entra).
See Also
2997844 - Error on Interview Scheduling with Outlook Integration using Modern Authentication - Recruiting Management
Keywords
interview settings, azure, service account configuration, interview scheduling, modern authentication, MailboxNotEnabledForRESTAPI, mailbox, inactive, soft-deleted, hosted on-premise , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem
SAP Knowledge Base Article - Public