Symptom
After an event is triggered on the sales order from S/4HANA Public Cloud to an external system, this event call is not recorded into the sales order change log. Therefore, it's not possible to track if the event was processed correctly, neither the date and time of its occurrence.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Change logs can be checked in different ways:
- Using the app Display Sales Orders (VA03): go to Menu > Environment > Changes
- Using the app Display Change Logs - Sales Documents (ID: F7356)
Cause
This is the system expected behavior.
Resolution
A change log contains changes that have been made to the sales document. Each log entry stores information about a change to the document header, a document item, or a schedule line, and the change is logged on field or table level:
- Table level: the system logs a change on table level when an entry is created in or deleted from a table.
- For example, when a sales order item is created, the system logs a change on table level because a new entry is generated in the item table.
- Field level: the system logs a change on field level when the value of a field is altered.
- For example, when order reason "001" is changed to "002" or removed).
See Also
Keywords
sales order, sales document, change log, changes, environment, insert, delete, change, table entry, field entry, log, log entry, external system, CPI, CPQ, integration, event trigger, event log , KBA , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem
SAP Knowledge Base Article - Public