SAP Knowledge Base Article - Public

3671488 - Template Not Visible for Agent in Email Compose

Symptom

When composing an email in any entity within the SAP Sales and Service Cloud Version 2, you notice the templates are not displayed, even though there are available templates created in the system to use with emails.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Logon to the SAP Sales and Service Cloud Version 2.
  2. Navigate to any entity which uses emails e.g. Guided Selling work list.
  3. Open any Opportunity.
  4. Click + Create.
  5. Click Email.
  6. Click Add Template.
  7. See no templates are displayed.

Cause

The agent does not have the Business Service templateService (sap.crm.service.templateService) and respective Templates App added to his business role, hence, he is unable to see the templates available.

Resolution

Ensure the business role of the affected agent has proper access to the Business Service templateService (sap.crm.service.templateService) and to the Templates App, so that the agent can see the available templates when composing an email.

Keywords

Template, Service, TemplateService, Business Role, Business, Role, Access, Access Rights, Rights, App, Missing Access, Missing, Blank, No Templates, Available, Email, V2, Version 2, SAP Service Cloud Version 2, templateService, sap.crm.service.templateService, , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions