Symptom
The assignment profile has been updated to include/exclude users. After the process is completed, the assignments are maintained/not added to the target users.
This scenario impacts 2 different processes of the Assignment Profile:
- Assignments to be made.
- Assignments to be removed.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Configure an Assignment Profile to assign or remove items from User's Learning Plan >
- The job is executed without apparent errors >
- The results are not fully updated, because for some users the assignments were either not added or removed >
- Checking on the Background Jobs, an error is noticed.
Cause
The cause for this issue is that the Assignment Profile synchronization failed during its execution. To check the Assignment Profile sync job, please navigate to:
- Learning Administration > System Administration >
- Background Jobs >
- If it's known the admin who performed the changes in the Assignment Profile, set its ID under Owner field >
- If not, search for Status = Failed >
- Set the title = Execute Changes Assignment Profiles
- Check the results.
The exceptions seen in the error log are equal or similar to these:
- Exception update student self assigned qual to ap assigned
- Caused by: com.sap.db.jdbc.exceptions.SQLTransactionRollbackExceptionSapDB: [131]: transaction rolled back by lock wait timeout: TrexColumnUpdate failed on table 'CUSTOMER_SCHEMA:PA_STUD_QUAL' with error: transaction rolled back by lock wait timeout: Lock-wait time out exceeded [OWNER=OWNER_ID, TYPE=RECORD_LOCK, CURRENT_MODE=NON_KEY_EXCLUSIVE, REQUESTED_MODE=NON_KEY_EXCLUSIVE], rc=4628
- com.plateau.common.core.api.PlateauException: Could not propagate all/some of the entities. Successful entities are marked with valid statuses.*
*In order to check details of the error message, the reportStackTraceToUser setting must be enabled, check "See Also" for instructions on how to enable it if needed.
Resolution
The resolution to this issue is to the following: Once the cause above is identified, the admin operating the Assignment Profile has two options to correct the issue.
Solution #1 - This is recommended to scenarios where the number of impacted users is not accountable:
- Revert the Assignment Profile rules back to what it was before the AP sync failed.
- Sync it (this means to Execute the AP Changes).
- Now make the new changes again.
- Sync the AP again and make sure it will finish successfully.
Solution #2 - This is recommended when the Admin knows how many users are impacted (and also recommended if the number of affected users is low):
- Edit the Assignment Profile rule to include/exclude the users.
- Sync it (this means to Execute the AP Changes).
- Now edit the rule to include/exclude the users again.
- Sync the AP again and make sure it will finish successfully.
See Also
Keywords
Assignment, profile, course, item, program, curriculum, remove, add, assign, unassign, enroll, sync, synchronization, SQLTransactionRollbackExceptionSapDB, propagate, execute, changes, update, ap, TrexColumnUpdate, Could not propagate all/some of the entities. Successful entities are marked with valid statuses. , KBA , LOD-SF-LMS-ASP , Assignment Profile , Problem
SAP Knowledge Base Article - Public