Symptom
- Error occurs when deleting the Owner in the Account Header.
- Error message: "Please enter an employee".
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center
- Go to the Accounts view
- Click Edit icon
- Clear the Owner in the Owner field
- Click Enter
Result: An error occurs with an error message.
Cause
- The issue happens only if there are many entities in the Account Team facet, and the Owner is not listed on the first page
- The issue happens only if the clearing of the Owner of the Account Header happens when the Owner in the Account Team facet is not displayed. *If clearing the Owner action happens when the Owner is displayed in the Account Team facet, the issue does not happen
- The functionality to clear the owner field is implemented in the CLASS, which only works on the current page of the Account Team
- If the Owner in the Account Team is not on the first page, when clearing the Owner of the Account Header, it only removes the name in the line but not the whole line of the Owner in the Account Team facet, so the issue & the message happen
Resolution
To change the page size of the Account Team list from the default value of 10 to a higher value (e.g. 20) via adaptation so that the Owner in the Account Team is displayed on the first page of the Account Team facet.
Keywords
Please enter an employee, account team, clear, delete, remove, owner, error, message, account team , KBA , LOD-CRM-ACC , Account , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public