SAP Knowledge Base Article - Public

3672126 - Employee Claim Record not created for Trigger Event Based Reimbursement - Employee Central

Symptom

An employee is eligible for a Reimbursement with Trigger Event, but the Claim is not created. 

Environment

SuccessFactors Employee Central

Reproducing the Issue

  1. Employee is Eligible for the Benefit;
  2. The job runs / the trigger process is completed (such as adding a Child or changing the Marital status to Married);
  3. Eligibility Rule sets the entitlement amount as expected;
  4. The Claim record is not created.

Cause

Attachment field is set as Required in the Benefit Employee Claim Object Definition. 

Resolution

Set the Attachment field to not be required on the Object Level. If this is necessary for the business requirement, the field can be set as Required via Manage Configuration UI (EmployeeClaimConfigUI is the standard one for Employee Claim). 

See Also

Life Event/ System Triggered Benefits

Keywords

Attachment, Required, Benefit Employee Claim, Configure Object Definition, Claim not created, GBF, reimbursement, voucher, service anniversary, gift , KBA , LOD-SF-EC-GBF , Global Benefits , Problem

Product

SAP SuccessFactors HCM Core 2505