Symptom
- Only contracts with "Active" status are visible under "Contract Items" in the Sales Order.
- Contracts with "Ready" or other statuses are not displayed in the standard filter.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open Sales Order.
- Use a customer with multiple contracts in various statuses, including "Ready".
- Under the customer, verify that contracts with "Ready" status are visible.
- In the Sales Order, select any line item and navigate to the "Contract Item" and "Contract" fields.
- Use the standard OVS (Object Value Selector) to pick contracts associated with the customer.
- Observe that only contracts with "Active" status are displayed in the OVS, while contracts with "Ready" status are not visible.
Cause
"Ready" or "Draft" contracts are not shown as "Applicable Contract Items" because the system is designed to only show items from contracts that are in an "Active" status Or in Open External Status.
This is a standard configuration to ensure only currently valid contracts and their associated items are used for product and pricing calculations in a sales order or other document.
Resolution
This is standard system behavior.
Keywords
contract items, active contracts, sales order, ready status, standard filter , KBA , LOD-LE-COP , Contract Processing , Bug Filed
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public