SAP Knowledge Base Article - Public

3672296 - Database analysis user deactivation due to excessive audit logs in SAP Datasphere

Symptom

In the Data Analysis Users screen of the Datasphere system configuration, the users are shown as deactivated and locked, as depicted in the following picture, with the tip: "The user is deactivated due to too many audit logs. Please clean up audit logs to reactivate the user again". After cleaning up the audit logs as per the Manage Database Analysis Users guide, the user remains deactivated.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."  

Environment

SAP Datasphere

Reproducing the Issue

  1. Login to the Datasphere tenant.
  2. Navigate to System --> Configuration --> Database Analysis users from the Database Access drop-down menu.
  3. Observe that the users are deactivated.

Cause

After the audit logs are cleaned up, the disk usage remains above the default threshold of 75%, resulting in the analysis users being deactivated.

Total disk usage (GB) can be obtained by operating the following SQL code in HANA Database Explorer:
SELECT sum(DISK_SIZE)/1024/1024/1024 FROM M_TABLE_PERSISTENCE_STATISTICS where schema_name in (select distinct space_ID from "DWC_TENANT_OWNER"."SPACE_METADATA" where space_ID!='$$global$$');

Resolution

  • Upsize the disk storage size, as per the note 3202634 - How to scale up your SAP Datasphere tenant.
  • Reduce the table data to lower the disk usage until it is below 75%.

Keywords

 deactivated user, user reactivation, database access, audit , KBA , DS-SM , Space Management , Problem

Product

SAP Datasphere all versions