SAP Knowledge Base Article - Public

3672363 - Emails sent from the customer's domains are being blocked due to being routed via Amazon SES domain "amazonses.com".

Symptom

  • Emails are being sent from the amazonses.com domain instead of the expected sender domain.
  • This behavior may cause emails to be flagged as spam or fail certain security checks.

Environment

  • SAP Business ByDesign

Cause

  • The email delivery issue occurs because outgoing messages are currently being sent via Amazon’s domain amazonses.com. This may sometimes cause emails to be flagged as spam or fail certain security checks.
  • They failed SPF alignment. The mail claimed to be from the customer’s domain but actually originated from Amazon SES’s IP ranges (amazonses.com).

Resolution

  1. Configure a Custom MAIL FROM Domain to ensure emails are sent using the organization's sub-domain.
  2. Provide the sub-domain that will be used for configuration.
  3. Ensure the sub-domain is structured as part of the main domain (e.g., sap.maindomain.com, mail.maindomain.com, invoices.maindomain.com, bounce.maindomain.com)
  4. Specify the sub-domain name and raise an incident to SAP. 
  5. SAP will update the DNS value after adding the sub-domain in the SES console. Once updated, you can add MX and TXT records in your DNS, and SAP will validate the same.
  6. The custom mail configuration of sub-domains will be completed. 

See Also

Keywords

amazonses, email delivery issue, sap business bydesign, custom mail from domain, sub-domain configuration, MX record, SPF record, email authentication, sender domain, DNS entries, DKIM enablement , KBA , AP-LM-AM-PCE , Process Communication Errors , AP-RC-OUT , Output Management , Problem

Product

SAP Business ByDesign all versions