Symptom
- When using an Employee Central Quick Action, selecting a value in a custom picklist causes the selected value to blank out.
- After the value disappears, the following warning message is displayed: "This value has changed based on your input."
- Despite the value blanking out, the data is saved without any impact.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to Picklist Center and create a new custom picklist.
- Select a Parent Picklist (for example: ISOCountryList).
- Add several new values to the custom picklist with Parent Picklist Values.
- Open Manage Business Configuration and add a custom string field under the jobInfo element.
- Associate this custom field with the newly created picklist and assign a Parent Field (for example: country-of-company).
- Create an onChange rule that sets another jobInfo field based on the value of the custom string field.
- Assign this rule to the custom field under the Trigger Rules section.
- Go to Manage Data and add the newly created custom picklist field to any Employee Central Quick Action template (for example: Suspension).
- Search for a user (for example: User A).
- From the Actions menu, select Suspension.
- Set a date and select a value from the custom picklist.
- Observe that the selected value blanks out and the following message appears: "This value has changed based on your input."
- Notice that despite the blank-out, the onChange rule executes successfully and the other jobInfo field value is correctly updated.
Cause
This is a Known Issue.
Resolution
The fix for this issue is planned to be deployed with the patch b2511p5. For patch timelines, please review SAP SuccessFactors Patches Knowledge Base
See Also
Keywords
KI2H2025, ECT-263038, PTCH-48430, INC16097687, suspension, return from suspension, quick action, dropdown, custom picklist, blanks out, event reason blank, value changed based on your input, quick action functionality
Product
SAP SuccessFactors Employee Central 2511
SAP Knowledge Base Article - Public