Symptom
- Newly introduced feature User Email Display Name is not being used for notifications triggered by users.
- Instead, the email notifications display the Admin Email Display Name or Default Display Name.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Access Learning Administration >
- Navigate to Global Application Settings > Mail tab >
- Populate the Admin Email Display Name, User Email Display Name and Default Display Name >
- Access Learning user side >
- Perform any action as a user that would trigger an email notification (i.e. enroll to a class) >
- Notice that the notification received displays the Admin Email Display Name.
Cause
- The same email address is set for both Application Notification Admin Email and Application Notification User Email.
- The notification triggered is sent from the Application Notification Admin Email.
Resolution
- The email address configured on the Application Notification User Email field needs to be different from the Application Notification Admin Email. Due to the logic used for the Sender Display Name if the email address is the same, the system will understand that it was triggered from the Application Notification Admin Email and show the Admin Email Display Name.
- Not all the notifications triggered by users are sent from the Application Notification User Email, only specific notifications like 'ApprovalProcessRequestApproved' will be sent from that email address.
See Also
Keywords
lms, learning, successfactors, sender display name, user email display name, admin email display name, sender, user, admin, name, display, email, notification, , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem
Product
SAP SuccessFactors Learning 2511
SAP Knowledge Base Article - Public